]> git.8kb.co.uk Git - pgpool-ii/pgpool-ii_2.2.5/blob - pgpool.spec
2.2.5 HEAD
[pgpool-ii/pgpool-ii_2.2.5] / pgpool.spec
1 Summary:        Pgpool is a connection pooling/replication server for PostgreSQL
2 Name:           pgpool-II
3 Version:        2.2
4 Release:        1%{?dist}
5 License:        BSD
6 Group:          Applications/Databases
7 URL:            http://pgpool.projects.PostgreSQL.org
8 Source0:        http://pgfoundry.org/frs/download.php/2108/%{name}-%{version}.tar.gz
9 Source1:        pgpool.init
10 Source2:        pgpool.sysconfig
11 Patch1:         pgpool.conf.sample.patch
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13 BuildRequires:  postgresql-devel pam-devel
14
15 Obsoletes:      postgresql-pgpool
16
17 %description
18 pgpool-II is a inherited project of pgpool (to classify from 
19 pgpool-II, it is sometimes called as pgpool-I). For those of 
20 you not familiar with pgpool-I, it is a multi-functional 
21 middle ware for PostgreSQL that features connection pooling, 
22 replication and load balancing functions. pgpool-I allows a 
23 user to connect at most two PostgreSQL servers for higher 
24 availability or for higher search performance compared to a 
25 single PostgreSQL server.
26
27 pgpool-II, on the other hand, allows multiple PostgreSQL 
28 servers (DB nodes) to be connected, which enables queries 
29 to be executed simultaneously on all servers. In other words, 
30 it enables "parallel query" processing. Also, pgpool-II can 
31 be started as pgpool-I by changing configuration parameters. 
32 pgpool-II that is executed in pgpool-I mode enables multiple 
33 DB nodes to be connected, which was not possible in pgpool-I. 
34
35 %package devel
36 Summary:        The  development files for pgpool-II
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}
39
40 %description devel
41 Development headers and libraries for pgpool-II.
42
43 %prep
44 %setup -q -n %{name}-%{version}
45 %patch1 -p0
46
47 %build
48 %configure --with-pgsql-includedir=%{_includedir}/pgsql --with-pgsql-lib=%{_libdir}/pgsql --disable-static --with-pam --disable-rpath --sysconfdir=%{_sysconfdir}/%{name}/
49
50 make %{?_smp_flags}
51
52 %install
53 rm -rf %{buildroot}
54 make %{?_smp_flags} DESTDIR=%{buildroot} install
55 install -d %{buildroot}%{_datadir}/%{name}
56 install -d %{buildroot}%{_sysconfdir}/%{name}
57 mv %{buildroot}/%{_sysconfdir}/%{name}/pcp.conf.sample %{buildroot}%{_sysconfdir}/%{name}/pcp.conf
58 mv %{buildroot}/%{_sysconfdir}/%{name}/pgpool.conf.sample %{buildroot}%{_sysconfdir}/%{name}/pgpool.conf
59 mv %{buildroot}/%{_sysconfdir}/%{name}/pool_hba.conf.sample %{buildroot}%{_sysconfdir}/%{name}/pool_hba.conf
60 install -d %{buildroot}%{_initrddir}
61 install -m 755 %{SOURCE1} %{buildroot}%{_initrddir}/pgpool
62 install -d %{buildroot}%{_sysconfdir}/sysconfig
63 install -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/pgpool
64
65 # nuke libtool archive and static lib
66 rm -f %{buildroot}%{_libdir}/libpcp.{a,la}
67
68 %clean
69 rm -rf %{buildroot}
70
71 %post 
72 /sbin/ldconfig
73 chkconfig --add pgpool
74
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(-,root,root,-)
79 %dir %{_datadir}/%{name}
80 %doc README README.euc_jp TODO COPYING INSTALL AUTHORS ChangeLog NEWS doc/pgpool-en.html doc/pgpool-ja.html doc/pgpool.css doc/tutorial-en.html doc/tutorial-ja.html
81 %{_bindir}/pgpool
82 %{_bindir}/pcp_attach_node
83 %{_bindir}/pcp_detach_node
84 %{_bindir}/pcp_node_count
85 %{_bindir}/pcp_node_info
86 %{_bindir}/pcp_proc_count
87 %{_bindir}/pcp_proc_info
88 %{_bindir}/pcp_stop_pgpool
89 %{_bindir}/pcp_recovery_node
90 %{_bindir}/pcp_systemdb_info
91 %{_bindir}/pg_md5
92 %{_mandir}/man8/pgpool*
93 %{_datadir}/%{name}/system_db.sql
94 %{_libdir}/libpcp.so.*
95 %{_datadir}/%{name}/pgpool.pam
96 %{_initrddir}/pgpool
97 %attr(764,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/*.conf
98 %config(noreplace) %{_sysconfdir}/sysconfig/pgpool
99
100 %files devel
101 %defattr(-,root,root,-)
102 %{_includedir}/pcp.h
103 %{_includedir}/pool_type.h
104 %{_libdir}/libpcp.so
105
106 %changelog
107 * Sun Mar 1 2009 Devrim Gunduz <devrim@CommandPrompt.com> 2.2-1
108 - Update to 2.2
109 - Fix URL
110 - Own /usr/share/pgpool-II directory.
111 - Fix pid file path in init script, per pgcore #81.
112 - Fix spec file -- we don't use short_name macro in pgcore spec file.
113 - Create pgpool pid file directory, per pgcore #81.
114 - Fix stop/start routines, also improve init script a bit.
115 - Install conf files to a new directory (/etc/pgpool-II), and get rid 
116   of sample conf files.
117
118 * Fri Aug 8 2008 Devrim Gunduz <devrim@CommandPrompt.com> 2.1-1
119 - Update to 2.1
120 - Removed temp patch #4.
121
122 * Sun Jan 13 2008 Devrim Gunduz <devrim@CommandPrompt.com> 2.0.1-1
123 - Update to 2.0.1
124 - Add a temp patch that will disappear in 2.0.2
125
126 * Fri Oct 5 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.2.1-1
127 - Update to 1.2.1
128
129 * Wed Aug 29 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.2-5
130 - Chmod sysconfig/pgpool to 644, not 755. Per BZ review.
131 - Run chkconfig --add pgpool during %%post.
132
133 * Thu Aug 16 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.2-4
134 - Fixed the directory name where sample conf files and sql files 
135   are installed.
136
137 * Sun Aug 5 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.2-3
138 - Added a patch for sample conf file to use Fedora defaults
139
140 * Sun Aug 5 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.2-2
141 - Added an init script for pgpool
142 - Added /etc/sysconfig/pgpool
143
144 * Wed Aug 1 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.2-1
145 - Update to 1.2
146
147 * Fri Jun 15 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.1.1-1
148 - Update to 1.1.1
149
150 * Sat Jun 2 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.1-1
151 - Update to 1.1
152 - added --disable-rpath configure parameter.
153 - Chowned sample conf files, so that they can work with pgpoolAdmin.
154
155 * Thu Apr 22 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.0.2-4
156 - Added postgresql-devel as BR, per bugzilla review.
157 - Added --disable-static flan, per bugzilla review.
158 - Removed superfluous manual file installs, per bugzilla review.
159
160 * Thu Apr 22 2007 Devrim Gunduz <devrim@CommandPrompt.com> 1.0.2-3
161 - Rebuilt for the correct tarball
162 - Fixed man8 file ownership, per bugzilla review #229321 
163
164 * Tue Feb 20 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-2
165 - Create proper devel package, drop -libs package
166 - Nuke rpath
167 - Don't install libtool archive and static lib
168 - Clean up %%configure line
169 - Use proper %%_smp_mflags
170 - Install config files properly, without .sample on the end
171 - Preserve timestamps on header files
172
173 * Tue Feb 20 2007 Devrim Gunduz <devrim@commandprompt.com> 1.0.2-1
174 - Update to 1.0.2-1
175
176 * Mon Oct 02 2006 Devrim Gunduz <devrim@commandprompt.com> 1.0.1-5
177 - Rebuilt
178
179 * Mon Oct 02 2006 Devrim Gunduz <devrim@commandprompt.com> 1.0.1-4
180 - Added -libs and RPM
181 - Fix .so link problem
182 - Cosmetic changes to spec file
183
184 * Thu Sep 27 2006 - Devrim GUNDUZ <devrim@commandprompt.com> 1.0.1-3
185 - Fix spec, per Yoshiyuki Asaba
186
187 * Thu Sep 26 2006 - Devrim GUNDUZ <devrim@commandprompt.com> 1.0.1-2
188 - Fixed rpmlint errors
189 - Fixed download url
190 - Added ldconfig for .so files
191
192 * Thu Sep 21 2006 - David Fetter <david@fetter.org> 1.0.1-1
193 - Initial build pgpool-II 1.0.1 for PgPool Global Development Group
194